Vulnerability · Published Jun 22, 2021 · Assigned by GitHub_M

CVE-2021-32644Cross-site Scripting in Random.php

Medium 6.4

In plain English

A medium-severity cross-site scripting in ampache from ampache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)0.8%top 41.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

Ampache is an open source web based audio/video streaming application and file manager. Due to a lack of input filtering versions 4.x.y are vulnerable to code injection in random.php. The attack requires user authentication to access the random.php page unless the site is running in demo mode. This issue has been resolved in 4.4.3.

Affected products (as reported)

VendorProductVersions
ampache ampache >= 4.0.0, < 4.4.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

References