Vulnerability · Published Jun 2, 2021 · Assigned by GitHub_M

CVE-2021-32625Redis vulnerability in STRALGO LCS on 32-bit systems

High 7.5

In plain English

A high-severity security flaw in redis from redis. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.1% (higher than 91% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)4.1%top 9.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis version 6.0 or newer, could be exploited using the STRALGO LCS command to corrupt the heap and potentially result with remote code execution. This is a result of an incomplete fix by CVE-2021-29477. The problem is fixed in version 6.2.4 and 6.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to use ACL configuration to prevent clients from using the STRALGO LCS command. On 64 bit systems which have the fixes of CVE-2021-29477 (6.2.3 or 6.0.13), it is sufficient to make sure that the proto-max-bulk-len config parameter is smaller than 2GB (default is 512MB).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20redis6.2.4-r0ALPINE-CVE-2021-32625
Alpine:v3.21redis6.2.4-r0ALPINE-CVE-2021-32625
Alpine:v3.22redis6.2.4-r0ALPINE-CVE-2021-32625
Alpine:v3.23redis6.2.4-r0ALPINE-CVE-2021-32625
Alpine:v3.24redis6.2.4-r0ALPINE-CVE-2021-32625
Debian:12redis5:6.0.14-1DEBIAN-CVE-2021-32625
Debian:13redis5:6.0.14-1DEBIAN-CVE-2021-32625
Debian:14redis5:6.0.14-1DEBIAN-CVE-2021-32625

Affected products (as reported)

VendorProductVersions
redis redis < 6.0.14>= 6.2.0, < 6.2.4

Weakness: CWE-680 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References