Vulnerability · Published May 17, 2021 · Assigned by GitHub_M
CVE-2021-32617Denial of service in Exiv2
Medium 4.7
In plain English
A medium-severity uncontrolled resource consumption in exiv2 from Exiv2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An inefficient algorithm (quadratic complexity) was found in Exiv2 versions v0.27.3 and earlier. The inefficient algorithm is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.4. Note that this bug is only triggered when _writing_ the metadata, which is a less frequently used Exiv2 operation than _reading_ the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `rm`.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | exiv2 | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-devel | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-doc | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-libs | 0.27.4-5.el8 | ALSA-2021:4173 |
| Alpine:v3.20 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-32617 |
| Alpine:v3.21 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-32617 |
| Alpine:v3.22 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-32617 |
| Alpine:v3.23 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-32617 |
| Alpine:v3.24 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-32617 |
| Debian:12 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-32617 |
| Debian:13 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-32617 |
| Debian:14 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-32617 |
| Rocky Linux:8 | exiv2 | 0:0.27.4-5.el8 | RLSA-2021:4173 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
References
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-w8mv-g8qq-36mj
- https://github.com/Exiv2/exiv2/pull/1657
- FEDORA-2021-d1d5a0bf0f vendor-advisory
- FEDORA-2021-8253c78bd7 vendor-advisory
- FEDORA-2021-bdba47348c vendor-advisory
- FEDORA-2021-8917c5d9d2 vendor-advisory
- GLSA-202312-06 vendor-advisory