Vulnerability · Published Jul 15, 2023 · Assigned by mitre

CVE-2021-31294

Medium 5.9

In plain English

A medium-severity security flaw in the redis package (Debian). Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.9Medium
Exploit odds (30 days)1.3%top 29.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Redis before 6cbea7d allows a replica to cause an assertion failure in a primary server by sending a non-administrative command (specifically, a SET command). NOTE: this was fixed for Redis 6.2.x and 7.x in 2021. Versions before 6.2 were not intended to have safety guarantees related to this.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12redis5:7.0.1-4DEBIAN-CVE-2021-31294
Debian:13redis5:7.0.1-4DEBIAN-CVE-2021-31294
Debian:14redis5:7.0.1-4DEBIAN-CVE-2021-31294
Ubuntu:22.04:LTSredisno fix listedUBUNTU-CVE-2021-31294

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References