Vulnerability · Published May 19, 2021 · Assigned by GitHub_M

CVE-2021-29625XSS in doc_link

High 7.5

In plain English

A high-severity cross-site scripting in adminer from vrana. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 9.6% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)9.6%top 4.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Nuclei

Official description

Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12adminer4.7.9-2DEBIAN-CVE-2021-29625
Debian:13adminer4.7.9-2DEBIAN-CVE-2021-29625
Debian:14adminer4.7.9-2DEBIAN-CVE-2021-29625
Packagistvrana/adminer4.8.1GHSA-2v82-5746-vwqc

Affected products (as reported)

VendorProductVersions
vrana adminer >= 4.7.8, < 4.8.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References