Vulnerability · Published May 13, 2021 · Assigned by GitHub_M

CVE-2021-29510Use of "infinity" as an input to datetime and date fields causes infinite loop in pydantic

Low 3.3

In plain English

A low-severity infinite loop in pydantic from samuelcolvin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.3Low
Exploit odds (30 days)1.0%top 37.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Pydantic is a data validation and settings management using Python type hinting. In affected versions passing either `'infinity'`, `'inf'` or `float('inf')` (or their negatives) to `datetime` or `date` fields causes validation to run forever with 100% CPU usage (on one CPU). Pydantic has been patched with fixes available in the following versions: v1.8.2, v1.7.4, v1.6.2. All these versions are available on pypi(https://pypi.org/project/pydantic/#history), and will be available on conda-forge(https://anaconda.org/conda-forge/pydantic) soon. See the changelog(https://pydantic-docs.helpmanual.io/) for details. If you absolutely can't upgrade, you can work around this risk using a validator(https://pydantic-docs.helpmanual.io/usage/validators/) to catch these values. This is not an ideal solution (in particular you'll need a slightly different function for datetimes), instead of a hack like this you should upgrade pydantic. If you are not using v1.8.x, v1.7.x or v1.6.x and are unable to upgrade to a fixed version of pydantic, please create an issue at https://github.com/samuelcolvin/pydantic/issues requesting a back-port, and we will endeavour to release a patch for earlier versions of pydantic.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12pydantic1.7.4-1DEBIAN-CVE-2021-29510
Debian:13pydantic1.7.4-1DEBIAN-CVE-2021-29510
Debian:14pydantic1.7.4-1DEBIAN-CVE-2021-29510
PyPIpydantic1.6.2GHSA-5jqp-qgf6-3pvh
PyPIpydantic1.6.2, 1.7.4, 1.8.2PYSEC-2021-47
PyPIpydantic1.8.2GHSA-5jqp-qgf6-3pvh
PyPIpydantic1.7.4GHSA-5jqp-qgf6-3pvh

Affected products (as reported)

VendorProductVersions
samuelcolvin pydantic >= 1.8.0, < 1.8.2>= 1.7.0, < 1.7.4< 1.6.2

Weakness: CWE-835 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References