Vulnerability · Published May 13, 2021 · Assigned by GitHub_M
CVE-2021-29506Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.
Medium 6.5
In plain English
A medium-severity uncontrolled resource consumption in graphhopper from graphhopper. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.graphhopper:graphhopper-nav | 2.4 | GHSA-hf44-3mx6-vhhw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| graphhopper | graphhopper | >= 2.0, < 2.4 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H