Vulnerability · Published Apr 27, 2021 · Assigned by GitHub_M

CVE-2021-29476Insecure Deserialization of untrusted data in rmccue/requests

Critical 9.8

In plain English

A critical-severity unsafe deserialization in Requests from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)2.1%top 17.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.5.3+dfsg1-1DEBIAN-CVE-2021-29476
Debian:13wordpress5.5.3+dfsg1-1DEBIAN-CVE-2021-29476
Debian:14wordpress5.5.3+dfsg1-1DEBIAN-CVE-2021-29476
Packagistrmccue/requests1.8.0GHSA-52qp-jpq7-6c54

Affected products (as reported)

VendorProductVersions
WordPress Requests >= 1.6.0, < 1.8.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References