Vulnerability · Published Apr 26, 2021 · Assigned by GitHub_M
CVE-2021-29473Out-of-bounds read in Exiv2::Jp2Image::doWriteMetadata
Low 2.5
In plain English
A low-severity out-of-bounds read in exiv2 from Exiv2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4. Please see our security policy for information about Exiv2 security.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | exiv2 | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-devel | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-doc | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-libs | 0.27.4-5.el8 | ALSA-2021:4173 |
| Alpine:v3.20 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-29473 |
| Alpine:v3.21 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-29473 |
| Alpine:v3.22 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-29473 |
| Alpine:v3.23 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-29473 |
| Alpine:v3.24 | exiv2 | 0.27.3-r2 | ALPINE-CVE-2021-29473 |
| Debian:12 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-29473 |
| Debian:13 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-29473 |
| Debian:14 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-29473 |
| Rocky Linux:8 | exiv2 | 0:0.27.4-5.el8 | RLSA-2021:4173 |
Affected products (as reported)
Weakness: CWE-125 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
References
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-7569-phvm-vwc2
- https://github.com/github/advisory-review/pull/1587
- https://github.com/Exiv2/exiv2/security/policy
- FEDORA-2021-10d7331a31 vendor-advisory
- FEDORA-2021-2d860da728 vendor-advisory
- FEDORA-2021-96a5dabcfa vendor-advisory
- FEDORA-2021-be94728b95 vendor-advisory
- DSA-4958 vendor-advisory
- [debian-lts-announce] 20210830 [SECURITY] [DLA 2750-1] exiv2 security update mailing-list
- GLSA-202312-06 vendor-advisory