Vulnerability · Published Apr 20, 2021 · Assigned by GitHub_M

CVE-2021-29459XSS Cross Site Scripting

Critical 9.6

In plain English

A critical-severity cross-site scripting in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.6Critical
Exploit odds (30 days)1.1%top 33.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-oldcore12.6.3GHSA-5c66-v29h-xjh8
Mavenorg.xwiki.platform:xwiki-platform-oldcore12.8GHSA-5c66-v29h-xjh8
Mavenorg.xwiki.platform:xwiki-platform-web12.6.3GHSA-5c66-v29h-xjh8
Mavenorg.xwiki.platform:xwiki-platform-web12.8GHSA-5c66-v29h-xjh8

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform < 12.6.3>= 12.6.4, < 12.8

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L

References