Vulnerability · Published Apr 19, 2021 · Assigned by GitHub_M
CVE-2021-29458Out-of-bounds read in Exiv2::Internal::CrwMap::encode
Medium 5.5
In plain English
A medium-severity out-of-bounds read in exiv2 from Exiv2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | exiv2 | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-devel | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-doc | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-libs | 0.27.4-5.el8 | ALSA-2021:4173 |
| Alpine:v3.20 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29458 |
| Alpine:v3.21 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29458 |
| Alpine:v3.22 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29458 |
| Alpine:v3.23 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29458 |
| Alpine:v3.24 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29458 |
| Debian:12 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-29458 |
| Debian:13 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-29458 |
| Debian:14 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-29458 |
| Rocky Linux:8 | exiv2 | 0:0.27.4-5.el8 | RLSA-2021:4173 |
Affected products (as reported)
Weakness: CWE-125
References
- https://github.com/Exiv2/exiv2/issues/1530
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-57jj-75fm-9rq5
- https://github.com/Exiv2/exiv2/pull/1536
- FEDORA-2021-10d7331a31 vendor-advisory
- FEDORA-2021-be94728b95 vendor-advisory
- [debian-lts-announce] 20230110 [SECURITY] [DLA 3265-1] exiv2 security update mailing-list
- GLSA-202312-06 vendor-advisory