Vulnerability · Published Apr 19, 2021 · Assigned by GitHub_M
CVE-2021-29457Heap buffer overflow in Exiv2::Jp2Image::doWriteMetadata
High 7.8
In plain English
A high-severity heap buffer overflow in exiv2 from Exiv2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A heap buffer overflow was found in Exiv2 versions v0.27.3 and earlier. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when _writing_ the metadata, which is a less frequently used Exiv2 operation than _reading_ the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | exiv2 | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-devel | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-doc | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-libs | 0.27.4-5.el8 | ALSA-2021:4173 |
| Alpine:v3.20 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29457 |
| Alpine:v3.21 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29457 |
| Alpine:v3.22 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29457 |
| Alpine:v3.23 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29457 |
| Alpine:v3.24 | exiv2 | 0.27.3-r1 | ALPINE-CVE-2021-29457 |
| Debian:12 | exiv2 | 0.27.3-3.1 | DEBIAN-CVE-2021-29457 |
| Debian:13 | exiv2 | 0.27.3-3.1 | DEBIAN-CVE-2021-29457 |
| Debian:14 | exiv2 | 0.27.3-3.1 | DEBIAN-CVE-2021-29457 |
| Rocky Linux:8 | exiv2 | 0:0.27.4-5.el8 | RLSA-2021:4173 |
Affected products (as reported)
Weakness: CWE-122
References
- https://github.com/Exiv2/exiv2/issues/1529
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-v74w-h496-cgqm
- https://github.com/Exiv2/exiv2/pull/1534
- FEDORA-2021-10d7331a31 vendor-advisory
- FEDORA-2021-be94728b95 vendor-advisory
- DSA-4958 vendor-advisory
- [debian-lts-announce] 20210830 [SECURITY] [DLA 2750-1] exiv2 security update mailing-list
- GLSA-202312-06 vendor-advisory