Vulnerability · Published Apr 15, 2021 · Assigned by GitHub_M

CVE-2021-29450WordPress Authenticated disclosure of password-protected posts and pages

Medium 6.5

In plain English

A medium-severity information exposure in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)2.1%top 18.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.7.1+dfsg1-1DEBIAN-CVE-2021-29450
Debian:13wordpress5.7.1+dfsg1-1DEBIAN-CVE-2021-29450
Debian:14wordpress5.7.1+dfsg1-1DEBIAN-CVE-2021-29450
Ubuntu:22.04:LTSwordpressno fix listedUBUNTU-CVE-2021-29450
Ubuntu:24.04:LTSwordpressno fix listedUBUNTU-CVE-2021-29450
Ubuntu:25.10wordpressno fix listedUBUNTU-CVE-2021-29450
Ubuntu:26.04:LTSwordpressno fix listedUBUNTU-CVE-2021-29450
Ubuntu:26.10wordpressno fix listedUBUNTU-CVE-2021-29450

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop >= 4.70,< 5.7.1

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References