Vulnerability · Published Apr 15, 2021 · Assigned by apache

CVE-2021-27850Bypass of the fix for CVE-2019-0195

Critical 9.8

In plain English

A critical-severity information exposure in Apache Tapestry from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 93.6% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)93.6%top 0.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling3Metasploit, Nuclei, Public PoC

Official description

A critical unauthenticated remote code execution vulnerability was found all recent versions of Apache Tapestry. The affected versions include 5.4.5, 5.5.0, 5.6.2 and 5.7.0. The vulnerability I have found is a bypass of the fix for CVE-2019-0195. Recap: Before the fix of CVE-2019-0195 it was possible to download arbitrary class files from the classpath by providing a crafted asset file URL. An attacker was able to download the file `AppModule.class` by requesting the URL `http://localhost:8080/assets/something/services/AppModule.class` which contains a HMAC secret key. The fix for that bug was a blacklist filter that checks if the URL ends with `.class`, `.properties` or `.xml`. Bypass: Unfortunately, the blacklist solution can simply be bypassed by appending a `/` at the end of the URL: `http://localhost:8080/assets/something/services/AppModule.class/` The slash is stripped after the blacklist check and the file `AppModule.class` is loaded into the response. This class usually contains the HMAC secret key which is used to sign serialized Java objects. With the knowledge of that key an attacker can sign a Java gadget chain that leads to RCE (e.g. CommonsBeanUtils1 from ysoserial). Solution for this vulnerability: * For Apache Tapestry 5.4.0 to 5.6.1, upgrade to 5.6.2 or later. * For Apache Tapestry 5.7.0, upgrade to 5.7.1 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.tapestry:tapestry-core5.6.3GHSA-mj8x-cpr8-x39h
Mavenorg.apache.tapestry:tapestry-core5.7.1GHSA-mj8x-cpr8-x39h

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tapestry Apache Tapestry 5.5.0Apache Tapestry 5.7.0Apache Tapestry 5.4.5 – before Apache Tapestry 5.4.0*Apache Tapestry 5.6.2 – before Apache Tapestry 5.6.0*

Weakness: CWE-200, CWE-502

References