Vulnerability · Published Mar 17, 2021 · Assigned by mitre
CVE-2021-27292
High 7.5
In plain English
A high-severity security flaw in the node-ua-parser-js package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.4% (higher than 89% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)3.4%top 11.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-ua-parser-js | 0.7.24+ds-1 | DEBIAN-CVE-2021-27292 |
| Debian:13 | node-ua-parser-js | 0.7.24+ds-1 | DEBIAN-CVE-2021-27292 |
| Debian:14 | node-ua-parser-js | 0.7.24+ds-1 | DEBIAN-CVE-2021-27292 |
| Ubuntu:22.04:LTS | node-ua-parser-js | no fix listed | UBUNTU-CVE-2021-27292 |
| npm | ua-parser-js | 0.7.24 | GHSA-78cj-fxph-m83p |