Vulnerability · Published Aug 30, 2021 · Assigned by puppet

CVE-2021-27018

High 7.5

In plain English

A high-severity security flaw in Puppet Remediate. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).

Severity (CVSS NVD)7.5High
Exploit odds (30 days)0.5%top 54.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The mechanism which performs certificate validation was discovered to have a flaw that resulted in certificates signed by an internal certificate authority to not be properly validated. This issue only affects clients that are configured to utilize Tenable.sc as the vulnerability data source.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSpuppetno fix listedUBUNTU-CVE-2021-27018

Affected products (as reported)

VendorProductVersions
n/a Puppet Remediate Affects Puppet Remediate prior to 2.0, resolved in 2.0

References