Vulnerability · Published Mar 3, 2021 · Assigned by mitre

CVE-2021-26813

High 7.5

In plain English

A high-severity security flaw in the python-markdown2 package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 84% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)2.3%top 16.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-markdown22.3.10-1.1DEBIAN-CVE-2021-26813
Debian:13python-markdown22.3.10-1.1DEBIAN-CVE-2021-26813
Debian:14python-markdown22.3.10-1.1DEBIAN-CVE-2021-26813
PyPImarkdown22.4.0GHSA-jr9p-r423-9m2r
PyPImarkdown22.4.0PYSEC-2021-20
Ubuntu:22.04:LTSpython-markdown2no fix listedUBUNTU-CVE-2021-26813
Ubuntu:24.04:LTSpython-markdown2no fix listedUBUNTU-CVE-2021-26813
Ubuntu:25.10python-markdown2no fix listedUBUNTU-CVE-2021-26813
Ubuntu:26.04:LTSpython-markdown2no fix listedUBUNTU-CVE-2021-26813
Ubuntu:26.10python-markdown2no fix listedUBUNTU-CVE-2021-26813

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References