Vulnerability · Published May 6, 2021 · Assigned by mitre
CVE-2021-26543
High 8.8
In plain English
A high-severity security flaw in the git-parse package (npm). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)8.8High
Exploit odds (30 days)2.5%top 15.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
The "gitDiff" function in Wayfair git-parse <=1.0.4 has a command injection vulnerability. Clients of the git-parse library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. The issue has been resolved in version 1.0.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | git-parse | 1.0.5 | GHSA-m744-2jj8-vpfv |
Affected products (as reported)
References
- https://www.npmjs.com/package/git-parse x_refsource_MISC
- https://advisory.checkmarx.net/advisory/CX-2020-4302 x_refsource_MISC