Vulnerability · Published Aug 25, 2022 · Assigned by apache
CVE-2021-25642Apache Hadoop YARN remote code execution in ZKConfigurationStore of capacity scheduler
High 8.8
In plain English
A high-severity unsafe deserialization in Apache Hadoop from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.hadoop:hadoop-yarn-server | 2.10.2 | GHSA-rr2m-gffv-mgrj |
| Maven | org.apache.hadoop:hadoop-yarn-server | 3.2.4 | GHSA-rr2m-gffv-mgrj |
| Maven | org.apache.hadoop:hadoop-yarn-server | 3.3.4 | GHSA-rr2m-gffv-mgrj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Hadoop | 2.9.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.3, and 3.3.0 to 3.3.3 |
Weakness: CWE-502