Vulnerability · Published Feb 16, 2021 · Assigned by openssl

CVE-2021-23840Integer overflow in CipherUpdate

High 7.5

In plain English

A high-severity integer overflow in OpenSSL from OpenSSL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 50.7% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)50.7%top 1.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8edk2-ovmf20210527gite1999b264f1f-3.el8ALSA-2021:4198
Alpine:v3.20openssl1.1.1j-r0ALPINE-CVE-2021-23840
Alpine:v3.21openssl1.1.1j-r0ALPINE-CVE-2021-23840
Alpine:v3.22openssl1.1.1j-r0ALPINE-CVE-2021-23840
Alpine:v3.23openssl1.1.1j-r0ALPINE-CVE-2021-23840
Alpine:v3.24openssl1.1.1j-r0ALPINE-CVE-2021-23840
Debian:12openssl1.1.1j-1DEBIAN-CVE-2021-23840
Debian:13openssl1.1.1j-1DEBIAN-CVE-2021-23840
Debian:14openssl1.1.1j-1DEBIAN-CVE-2021-23840
Rocky Linux:8edk20:20210527gite1999b264f1f-3.el8RLSA-2021:4198
Rocky Linux:8openssl1:1.1.1k-4.el8RLSA-2021:4424

Affected products (as reported)

VendorProductVersions
OpenSSL OpenSSL Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i)Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x)

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References