Vulnerability · Published Jun 11, 2021 · Assigned by hackerone

CVE-2021-22895

Medium 5.9

In plain English

A medium-severity improper certificate validation in Nextcloud Desktop Client. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.9Medium
Exploit odds (30 days)1.0%top 35.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the "Register with a Provider" flow.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nextcloud-desktop3.3.1-1DEBIAN-CVE-2021-22895
Debian:13nextcloud-desktop3.3.1-1DEBIAN-CVE-2021-22895
Debian:14nextcloud-desktop3.3.1-1DEBIAN-CVE-2021-22895
Ubuntu:22.04:LTSnextcloud-desktopno fix listedUBUNTU-CVE-2021-22895
Ubuntu:24.04:LTSnextcloud-desktopno fix listedUBUNTU-CVE-2021-22895
Ubuntu:25.10nextcloud-desktopno fix listedUBUNTU-CVE-2021-22895
Ubuntu:26.04:LTSnextcloud-desktopno fix listedUBUNTU-CVE-2021-22895
Ubuntu:26.10nextcloud-desktopno fix listedUBUNTU-CVE-2021-22895

Affected products (as reported)

VendorProductVersions
n/a Nextcloud Desktop Client Fixed in 3.3.1

Weakness: CWE-295

References