Vulnerability · Published Jun 29, 2021 · Assigned by vmware
CVE-2021-22119
High 7.5
In plain English
A high-severity uncontrolled resource consumption in Spring Security. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 6.0% (higher than 93% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client Web and WebFlux application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session or multiple sessions.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.springframework.security:spring-security-core | 5.5.1 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-core | 5.4.7 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-core | 5.3.10 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-core | 5.2.11 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-oauth2-client | 5.5.1 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-oauth2-client | 5.4.7 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-oauth2-client | 5.3.10 | GHSA-w9jg-gvgr-354m |
| Maven | org.springframework.security:spring-security-oauth2-client | 5.2.11 | GHSA-w9jg-gvgr-354m |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | Spring Security | Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 |
Weakness: CWE-400
References
- https://tanzu.vmware.com/security/cve-2021-22119 x_refsource_MISC
- [portals-pluto-dev] 20210714 [jira] [Updated] (PLUTO-786) Upgrade to version Spring Framework 5.3.7 and Spring Security 5.5.1 due to CVE-2021-22112 and CVE-2021-22119 mailing-list, x_refsource_MLIST
- [portals-pluto-dev] 20210714 [jira] [Reopened] (PLUTO-786) Upgrade to version Spring Framework 5.3.7 and Spring Security 5.5.1 due to CVE-2021-22112 and CVE-2021-22119 mailing-list, x_refsource_MLIST
- [portals-pluto-dev] 20210714 [jira] [Closed] (PLUTO-786) Upgrade to version Spring Framework 5.3.7 and Spring Security 5.5.1 due to CVE-2021-22112 and CVE-2021-22119 mailing-list, x_refsource_MLIST
- [portals-pluto-dev] 20210714 [jira] [Comment Edited] (PLUTO-786) Upgrade to version Spring Framework 5.3.7 and Spring Security 5.5.1 due to CVE-2021-22112 and CVE-2021-22119 mailing-list, x_refsource_MLIST
- [portals-pluto-scm] 20210714 [portals-pluto] branch master updated: PLUTO-786 Upgrade to version Spring Framework 5.3.7 and Spring Security 5.5.1 due to CVE-2021-22112 and CVE-2021-22119 mailing-list, x_refsource_MLIST
- [nifi-issues] 20210726 [jira] [Created] (NIFI-8948) Upgrade Spring Framework to 5.3.9 and Spring Security to 5.5.1 mailing-list, x_refsource_MLIST
- https://www.oracle.com/security-alerts/cpujan2022.html x_refsource_MISC
- https://www.oracle.com/security-alerts/cpujul2022.html x_refsource_MISC