Vulnerability · Published Apr 21, 2021 · Assigned by GitHub_M
CVE-2021-21427Backport for CVE-2021-21024 Blind SQLi from Magento 2
Critical 9.1
In plain English
A critical-severity SQL injection in magento-lts from OpenMage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Magento-lts is a long-term support alternative to Magento Community Edition (CE). A vulnerability in magento-lts versions before 19.4.13 and 20.0.9 potentially allows an administrator unauthorized access to restricted resources. This is a backport of CVE-2021-21024. The vulnerability is patched in versions 19.4.13 and 20.0.9.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | openmage/magento-lts | 19.4.13 | GHSA-fvrf-9428-527m |
| Packagist | openmage/magento-lts | 20.0.9 | GHSA-fvrf-9428-527m |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMage | magento-lts | <= 19.4.12<= 20.0.8 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-fvrf-9428-527m x_refsource_CONFIRM