Vulnerability · Published Mar 26, 2021 · Assigned by GitHub_M
CVE-2021-21389BuddyPress privilege escalation via REST API
High 8.1
In plain English
A high-severity incorrect authorization in BuddyPress from buddypress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 14.8% (higher than 97% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | buddypress/buddypress | 7.2.1 | GHSA-m6j4-8r7p-wpp3 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| buddypress | BuddyPress | >= 5.0.0, < 7.2.1 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3 x_refsource_CONFIRM
- https://buddypress.org/2021/03/buddypress-7-2-1-security-release/ x_refsource_MISC
- https://codex.buddypress.org/releases/version-7-2-1/ x_refsource_MISC