Vulnerability · Published Apr 29, 2021 · Assigned by GitHub_M

CVE-2021-21388Command Injection Vulnerability in systeminformation

High 8.9

In plain English

A high-severity improper input validation in systeminformation from sebhildebrandt. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.9High
Exploit odds (30 days)1.9%top 20.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

systeminformation is an open source system and OS information library for node.js. A command injection vulnerability has been discovered in versions of systeminformation prior to 5.6.4. The issue has been fixed with a parameter check on user input. Please upgrade to version >= 5.6.4. If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() and other commands. Only allow strings, reject any arrays. String sanitation works as expected.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14node-systeminformationno fix listedDEBIAN-CVE-2021-21388
npmsysteminformation5.6.4GHSA-jff2-qjw8-5476

Affected products (as reported)

VendorProductVersions
sebhildebrandt systeminformation < 5.6.4

Weakness: CWE-20, CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:H

References