Vulnerability · Published Mar 23, 2021 · Assigned by GitHub_M

CVE-2021-21370Cross-Site Scripting in Content Preview (CType menu)

Medium 5.4

In plain English

A medium-severity cross-site scripting in TYPO3.CMS from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.9%top 41.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 it has been discovered that content elements of type _menu_ are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms9.5.25GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms11.1.1GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms10.4.14GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-backend10.4.14GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-backend11.1.1GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-backend7.6.51GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-backend8.7.40GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-backend9.5.25GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-core9.5.25GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-core11.1.1GHSA-x7hc-x7fm-f7qh
Packagisttypo3/cms-core10.4.14GHSA-x7hc-x7fm-f7qh

Affected products (as reported)

VendorProductVersions
TYPO3 TYPO3.CMS >= 7.0.0, <= 7.6.50>= 8.0.0, <= 8.7.39>= 9.0.0, <= 9.5.24>= 10.0.0, <= 10.4.13>= 11.0.0, <= 11.1.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References