Vulnerability · Published Mar 11, 2021 · Assigned by GitHub_M
CVE-2021-21364Generated Code Contains Local Information Disclosure Vulnerability
Medium 5.3
In plain English
A medium-severity information exposure in swagger-codegen from swagger-api. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
swagger-codegen is an open-source project which contains a template-driven engine to generate documentation, API clients and server stubs in different languages by parsing your OpenAPI / Swagger definition. In swagger-codegen before version 2.4.19, on Unix-Like systems, the system temporary directory is shared between all local users. When files/directories are created, the default `umask` settings for the process are respected. As a result, by default, most processes/apis will create files/directories with the permissions `-rw-r--r--` and `drwxr-xr-x` respectively, unless an API that explicitly sets safe file permissions is used. Because this vulnerability impacts generated code, the generated code will remain vulnerable until fixed manually! This vulnerability is fixed in version 2.4.19. Note this is a distinct vulnerability from CVE-2021-21363.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | io.swagger:swagger-codegen | 2.4.19 | GHSA-hpv8-9rq5-hq7w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| swagger-api | swagger-codegen | < 2.4.19 |
Weakness: CWE-200, CWE-378, CWE-732 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N