Vulnerability · Published Mar 9, 2021 · Assigned by GitHub_M

CVE-2021-21361Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin

Medium 5.3

In plain English

A medium-severity sensitive data in logs in security-research from JLLeitschuh. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.2%top 32.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed in version 3.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavencom.bmuschko:gradle-vagrant-plugin3.0.0GHSA-jpcm-4485-69p7

Affected products (as reported)

VendorProductVersions
JLLeitschuh security-research < 3.0.0

Weakness: CWE-532 · Vector: CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

References