Vulnerability · Published Mar 23, 2021 · Assigned by GitHub_M

CVE-2021-21339Cleartext storage of session identifier

Medium 5.9

In plain English

A medium-severity security flaw in TYPO3.CMS from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.9%top 39.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 6.2.57, 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 user session identifiers were stored in cleartext - without processing of additional cryptographic hashing algorithms. This vulnerability cannot be exploited directly and occurs in combination with a chained attack - like for instance SQL injection in any other component of the system. This is fixed in versions 6.2.57, 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms10.4.14GHSA-qx3w-4864-94ch
Packagisttypo3/cms11.1.1GHSA-qx3w-4864-94ch
Packagisttypo3/cms9.5.25GHSA-qx3w-4864-94ch
Packagisttypo3/cms-core10.4.14GHSA-qx3w-4864-94ch
Packagisttypo3/cms-core6.2.57GHSA-qx3w-4864-94ch
Packagisttypo3/cms-core9.5.25GHSA-qx3w-4864-94ch
Packagisttypo3/cms-core11.1.1GHSA-qx3w-4864-94ch
Packagisttypo3/cms-core7.6.51GHSA-qx3w-4864-94ch
Packagisttypo3/cms-core8.7.40GHSA-qx3w-4864-94ch

Affected products (as reported)

VendorProductVersions
TYPO3 TYPO3.CMS >= 6.2.0, <= 6.2.56>= 7.0.0, <= 7.6.50>= 8.0.0, <= 8.7.39>= 9.0.0, <= 9.5.24>= 10.0.0, <= 10.4.13>= 11.0.0, <= 11.1.0

Weakness: CWE-312 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

References