Vulnerability · Published Mar 10, 2021 · Assigned by GitHub_M

CVE-2021-21334environment variable leak

Medium 6.3

In plain English

A medium-severity security flaw in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)1.9%top 19.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20containerd1.4.4-r0ALPINE-CVE-2021-21334
Alpine:v3.21containerd1.4.4-r0ALPINE-CVE-2021-21334
Alpine:v3.22containerd1.4.4-r0ALPINE-CVE-2021-21334
Alpine:v3.23containerd1.4.4-r0ALPINE-CVE-2021-21334
Alpine:v3.24containerd1.4.4-r0ALPINE-CVE-2021-21334
Alpine:v3.20k3s1.20.5.1-r0ALPINE-CVE-2021-21334
Alpine:v3.21k3s1.20.5.1-r0ALPINE-CVE-2021-21334
Alpine:v3.22k3s1.20.5.1-r0ALPINE-CVE-2021-21334
Alpine:v3.23k3s1.20.5.1-r0ALPINE-CVE-2021-21334
Alpine:v3.24k3s1.20.5.1-r0ALPINE-CVE-2021-21334
Debian:12containerd1.4.4~ds1-1DEBIAN-CVE-2021-21334
Debian:13containerd1.4.4~ds1-1DEBIAN-CVE-2021-21334
Debian:14containerd1.4.4~ds1-1DEBIAN-CVE-2021-21334
Gogithub.com/containerd/containerd1.3.10GHSA-6g2q-w5j3-fwh4
Gogithub.com/containerd/containerd1.4.4GHSA-6g2q-w5j3-fwh4

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.3.10>= 1.4.0, < 1.4.4

Weakness: CWE-668 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

References