Vulnerability · Published Feb 8, 2021 · Assigned by GitHub_M
CVE-2021-21306Denial of Service in Marked
Medium 5.3
In plain English
A medium-severity uncontrolled resource consumption in marked from markedjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Marked is an open-source markdown parser and compiler (npm package "marked"). In marked from version 1.1.1 and before version 2.0.0, there is a Regular expression Denial of Service vulnerability. This vulnerability can affect anyone who runs user generated code through marked. This vulnerability is fixed in version 2.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | marked | 2.0.0 | GHSA-4r62-v4vq-hr96 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/markedjs/marked/security/advisories/GHSA-4r62-v4vq-hr96 x_refsource_CONFIRM
- https://github.com/markedjs/marked/issues/1927 x_refsource_MISC
- https://github.com/markedjs/marked/pull/1864 x_refsource_MISC
- https://github.com/markedjs/marked/commit/7293251c438e3ee968970f7609f1a27f9007bccd x_refsource_MISC
- https://www.npmjs.com/package/marked x_refsource_MISC