Vulnerability · Published Feb 8, 2021 · Assigned by GitHub_M

CVE-2021-21305Code Injection vulnerability in CarrierWave

High 7.4

In plain English

A high-severity injection in carrierwave from carrierwaveuploader. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 13.2% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)13.2%top 3.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-carrierwave1.3.2-1DEBIAN-CVE-2021-21305
RubyGemscarrierwave1.3.2GHSA-cf3w-g86h-35x4
RubyGemscarrierwave2.1.1GHSA-cf3w-g86h-35x4

Affected products (as reported)

VendorProductVersions
carrierwaveuploader carrierwave < 1.3.2>= 2.0.0, < 2.1.1

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

References