Vulnerability · Published Feb 11, 2021 · Assigned by GitHub_M

CVE-2021-21299Multiple Transfer-Encoding headers misinterprets request payload

Medium 4.8

In plain English

A medium-severity security flaw in hyper from hyperium. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.8% (higher than 92% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)4.8%top 8.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". To determine if vulnerable, all these things must be true: 1) Using hyper as an HTTP server (the client is not affected), 2) Using HTTP/1.1 (HTTP/2 does not use transfer-encoding), 3) Using a vulnerable HTTP proxy upstream to hyper. If an upstream proxy correctly rejects the illegal transfer-encoding headers, the desync attack cannot succeed. If there is no proxy upstream of hyper, hyper cannot start the desync attack, as the client will repair the headers before forwarding. This is fixed in versions 0.14.3 and 0.13.10. As a workaround one can take the following options: 1) Reject requests that contain a `transfer-encoding` header, 2) Ensure any upstream proxy handles `transfer-encoding` correctly.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rust-hyper0.14.19-1DEBIAN-CVE-2021-21299
Debian:13rust-hyper0.14.19-1DEBIAN-CVE-2021-21299
Debian:14rust-hyper0.14.19-1DEBIAN-CVE-2021-21299
Ubuntu:24.04:LTSrust-hyperno fix listedUBUNTU-CVE-2021-21299
Ubuntu:25.10rust-hyperno fix listedUBUNTU-CVE-2021-21299
Ubuntu:26.04:LTSrust-hyperno fix listedUBUNTU-CVE-2021-21299
Ubuntu:26.10rust-hyperno fix listedUBUNTU-CVE-2021-21299

Affected products (as reported)

VendorProductVersions
hyperium hyper < 0.13.10>= 0.14.0, < 0.14.3

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References