Vulnerability · Published Feb 26, 2021 · Assigned by GitHub_M
CVE-2021-21298Path traversal in Node-Red
Low 3.5
In plain English
A low-severity path traversal in node-red from node-red. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier has a vulnerability which allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with `projects.read` permission is able to access any file via the Projects API. The issue has been patched in Node-RED 1.2.8. The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @node-red/runtime | 1.2.8 | GHSA-m33v-338h-4v9f |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
References
- https://www.npmjs.com/package/%40node-red/runtime x_refsource_MISC
- https://github.com/node-red/node-red/releases/tag/1.2.8 x_refsource_MISC
- https://github.com/node-red/node-red/security/advisories/GHSA-m33v-338h-4v9f x_refsource_CONFIRM
- https://github.com/node-red/node-red/commit/74db3e17d075f23d9c95d7871586cf461524c456 x_refsource_MISC