Vulnerability · Published Feb 8, 2021 · Assigned by GitHub_M

CVE-2021-21290Local Information Disclosure Vulnerability in Netty on Unix-Like systems due temporary files

Medium 6.2

In plain English

A medium-severity security flaw in netty from netty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.2Medium
Exploit odds (30 days)1.8%top 21.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty before version 4.1.59.Final there is a vulnerability on Unix-like systems involving an insecure temp file. When netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. On unix-like systems, the temporary directory is shared between all user. As such, writing to this directory using APIs that do not explicitly set the file/directory permissions can lead to information disclosure. Of note, this does not impact modern MacOS Operating Systems. The method "File.createTempFile" on unix-like systems creates a random file, but, by default will create this file with the permissions "-rw-r--r--". Thus, if sensitive information is written to this file, other local users can read this information. This is the case in netty's "AbstractDiskHttpData" is vulnerable. This has been fixed in version 4.1.59.Final. As a workaround, one may specify your own "java.io.tmpdir" when you start the JVM or use "DefaultHttpDataFactory.setBaseDir(...)" to set the directory to something that is only readable by the current user.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12netty1:4.1.48-2DEBIAN-CVE-2021-21290
Debian:13netty1:4.1.48-2DEBIAN-CVE-2021-21290
Debian:14netty1:4.1.48-2DEBIAN-CVE-2021-21290
Mavenio.netty:nettyno fix listedGHSA-5mcr-gq6c-3hq2
Mavenio.netty:netty-codec-http4.1.59.FinalGHSA-5mcr-gq6c-3hq2
Mavenorg.jboss.netty:nettyno fix listedGHSA-5mcr-gq6c-3hq2
Rocky Linux:8libdb0:5.3.28-42.el8_4RLSA-2022:5498
Ubuntu:22.04:LTSnetty1:4.1.48-4+deb11u1build0.22.04.1USN-6049-1
Ubuntu:22.04:LTSnetty1:4.1.48-4+deb11u1build0.22.04.1UBUNTU-CVE-2021-21290

Affected products (as reported)

VendorProductVersions
netty netty < 4.1.59.Final

Weakness: CWE-378, CWE-379 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References