Vulnerability · Published Jun 18, 2021 · Assigned by GitHub_M

CVE-2021-21281Buffer overflow due to unvalidated TCP data offset

High 7.0

In plain English

A high-severity buffer overflow in contiki-ng from contiki-ng. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities).

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)0.9%top 39.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Contiki-NG is an open-source, cross-platform operating system for internet of things devices. A buffer overflow vulnerability exists in Contiki-NG versions prior to 4.6. After establishing a TCP socket using the tcp-socket library, it is possible for the remote end to send a packet with a data offset that is unvalidated. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.

Affected products (as reported)

VendorProductVersions
contiki-ng contiki-ng < 4.6

Weakness: CWE-120 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H

References