Vulnerability · Published Jun 18, 2021 · Assigned by GitHub_M
CVE-2021-21280Out-of-bounds write when processing 6LoWPAN extension headers
High 8.6
In plain English
A high-severity out-of-bounds write in contiki-ng from contiki-ng. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities).
Official description
Contiki-NG is an open-source, cross-platform operating system for internet of things devices. It is possible to cause an out-of-bounds write in versions of Contiki-NG prior to 4.6 when transmitting a 6LoWPAN packet with a chain of extension headers. Unfortunately, the written header is not checked to be within the available space, thereby making it possible to write outside the buffer. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| contiki-ng | contiki-ng | < 4.6 |
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
References
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-r768-hrhf-v592 x_refsource_CONFIRM
- https://github.com/contiki-ng/contiki-ng/pull/1409 x_refsource_MISC