Vulnerability · Published Jan 22, 2021 · Assigned by GitHub_M
CVE-2021-21270Cleartext Storage of Sensitive Information
Medium 6.2
In plain English
A medium-severity security flaw in OctopusDSC from OctopusDeploy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).
Severity (CVSS 3.1)6.2Medium
Exploit odds (30 days)0.3%top 79.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
OctopusDSC is a PowerShell module with DSC resources that can be used to install and configure an Octopus Deploy Server and Tentacle agent. In OctopusDSC version 4.0.977 and earlier a customer API key used to connect to Octopus Server is exposed via logging in plaintext. This vulnerability is patched in version 4.0.1002.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OctopusDeploy | OctopusDSC | < 4.0.1002 |
Weakness: CWE-319 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/OctopusDeploy/OctopusDSC/security/advisories/GHSA-phmm-rfg9-94fm x_refsource_CONFIRM
- https://github.com/OctopusDeploy/OctopusDSC/releases/tag/v4.0.1002 x_refsource_MISC
- https://github.com/OctopusDeploy/OctopusDSC/pull/270 x_refsource_MISC
- https://github.com/OctopusDeploy/OctopusDSC/commit/24b448e6ac964ed938475add494a145c0473ac42 x_refsource_MISC