Vulnerability · Published Jan 29, 2021 · Assigned by GitHub_M

CVE-2021-21254Regular expression Denial of Service in Markdown plugin

Medium 6.5

In plain English

A medium-severity uncontrolled resource consumption in ckeditor5 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.8%top 21.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

CKEditor 5 is an open source rich text editor framework with a modular architecture. The CKEditor 5 Markdown plugin (@ckeditor/ckeditor5-markdown-gfm) before version 25.0.0 has a regex denial of service (ReDoS) vulnerability. The vulnerability allowed to abuse link recognition regular expression, which could cause a significant performance drop resulting in browser tab freeze. It affects all users using CKEditor 5 Markdown plugin at version <= 24.0.0. The problem has been recognized and patched. The fix will be available in version 25.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@ckeditor/ckeditor5-markdown-gfm25.0.0GHSA-hgmg-hhc8-g5wr

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor5 < 25.0.0

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References