Vulnerability · Published Jan 21, 2021 · Assigned by GitHub_M

CVE-2021-21238SAML XML Signature wrapping

Medium 6.5

In plain English

A medium-severity security flaw in pysaml2 from IdentityPython. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.1%top 34.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to validate signed SAML documents are impacted. The vulnerability is a variant of XML Signature wrapping because it did not validate the SAML document against an XML schema. This allowed invalid XML documents to be processed and such a document can trick pysaml2 with a wrapped signature. This is fixed in PySAML2 6.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20py3-saml26.5.0-r0ALPINE-CVE-2021-21238
Alpine:v3.21py3-saml26.5.0-r0ALPINE-CVE-2021-21238
Alpine:v3.22py3-saml26.5.0-r0ALPINE-CVE-2021-21238
Alpine:v3.23py3-saml26.5.0-r0ALPINE-CVE-2021-21238
Alpine:v3.24py3-saml26.5.0-r0ALPINE-CVE-2021-21238
Debian:12python-pysaml26.5.1-1DEBIAN-CVE-2021-21238
Debian:13python-pysaml26.5.1-1DEBIAN-CVE-2021-21238
Debian:14python-pysaml26.5.1-1DEBIAN-CVE-2021-21238
PyPIpysaml26.5.0GHSA-f4g9-h89h-jgv9
PyPIpysaml26.5.0PYSEC-2021-48
Ubuntu:22.04:LTSpython-pysaml2no fix listedUBUNTU-CVE-2021-21238

Affected products (as reported)

VendorProductVersions
IdentityPython pysaml2 < 6.5.0

Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References