Vulnerability · Published Mar 15, 2021 · Assigned by redhat

CVE-2021-20279

Medium 5.4

In plain English

A medium-severity cross-site scripting in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.4Medium
Exploit odds (30 days)1.0%top 37.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.10.2GHSA-h7h6-fwpv-ggvx
Packagistmoodle/moodle3.9.5GHSA-h7h6-fwpv-ggvx
Packagistmoodle/moodle3.8.8GHSA-h7h6-fwpv-ggvx
Packagistmoodle/moodle3.5.17GHSA-h7h6-fwpv-ggvx

Affected products (as reported)

VendorProductVersions
n/a moodle Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17

Weakness: CWE-79

References