Vulnerability · Published Nov 19, 2020 · Assigned by hackerone

CVE-2020-8277

High 7.5

In plain English

A high-severity uncontrolled resource consumption in Node from NodeJS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 54.2% (higher than 99.0% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)54.2%top 1.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8nodejs-nodemon2.0.3-1.module_el8.4.0+2521+c668cc9fALSA-2021:0551
AlmaLinux:8nodejs-nodemon1.18.3-1.module_el8.3.0+2047+b07ac28eALSA-2020:5499
AlmaLinux:8nodejs-nodemon1.18.3-1.module_el8.3.0+2023+d2377ea3ALSA-2020:5499
AlmaLinux:8nodejs-packaging17-3.module_el8.3.0+2023+d2377ea3ALSA-2020:5499
AlmaLinux:8nodejs-packaging23-3.module_el8.5.0+254+b4526b16ALSA-2021:0551
AlmaLinux:8nodejs-packaging23-3.module_el8.4.0+2522+3bd42762ALSA-2021:0551
AlmaLinux:8nodejs-packaging17-3.module_el8.4.0+2224+b07ac28eALSA-2020:5499
AlmaLinux:8nodejs-packaging17-3.module_el8.4.0+2521+c668cc9fALSA-2020:5499
Alpine:v3.20nodejs14.15.1-r0ALPINE-CVE-2020-8277
Alpine:v3.21nodejs14.15.1-r0ALPINE-CVE-2020-8277
Alpine:v3.22nodejs14.15.1-r0ALPINE-CVE-2020-8277
Alpine:v3.23nodejs14.15.1-r0ALPINE-CVE-2020-8277
Alpine:v3.24nodejs14.15.1-r0ALPINE-CVE-2020-8277
Alpine:v3.20nodejs-current15.3.0-r0ALPINE-CVE-2020-8277
Alpine:v3.21nodejs-current15.3.0-r0ALPINE-CVE-2020-8277
Alpine:v3.22nodejs-current15.3.0-r0ALPINE-CVE-2020-8277
Alpine:v3.23nodejs-current15.3.0-r0ALPINE-CVE-2020-8277
Alpine:v3.24nodejs-current15.3.0-r0ALPINE-CVE-2020-8277
Debian:12c-ares1.17.1-1DEBIAN-CVE-2020-8277
Debian:13c-ares1.17.1-1DEBIAN-CVE-2020-8277
Debian:14c-ares1.17.1-1DEBIAN-CVE-2020-8277
Rocky Linux:8nodejs-nodemon0:1.18.3-1.module+el8.3.0+101+f84c7154RLSA-2020:5499
Rocky Linux:8nodejs-nodemon0:2.0.3-1.module+el8.4.0+638+5344c6f7RLSA-2021:0551
Rocky Linux:8nodejs-nodemon0:2.0.3-1.module+el8.3.0+100+234774f7RLSA-2021:0551
Rocky Linux:8nodejs-nodemon0:2.0.3-1.module+el8.6.0+982+9fdca2d4RLSA-2021:0551
Rocky Linux:8nodejs-packaging0:17-3.module+el8.3.0+101+f84c7154RLSA-2020:5499
Rocky Linux:8nodejs-packaging0:23-3.module+el8.3.0+100+234774f7RLSA-2021:0551
Rocky Linux:8nodejs-packaging0:23-3.module+el8.7.0+1071+4bdda2a8RLSA-2021:0551
Rocky Linux:8nodejs-packaging0:23-3.module+el8.5.0+733+de4fee6cRLSA-2021:0551

Affected products (as reported)

VendorProductVersions
NodeJS Node 4.0 – before 4.*5.0 – before 5.*6.0 – before 6.*7.0 – before 7.*8.0 – before 8.*9.0 – before 9.*11.0 – before 11.*12.0 – before 12.19.1

Weakness: CWE-400

References