Vulnerability · Published Mar 20, 2020 · Assigned by hackerone

CVE-2020-8137

Critical 9.8

In plain English

A critical-severity code injection in blamer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.3% (higher than 91% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)4.3%top 8.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Code injection vulnerability in blamer 1.0.0 and earlier may result in remote code execution when the input can be controlled by an attacker.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmblamer1.0.1GHSA-7vm7-j8p7-h346

Affected products (as reported)

VendorProductVersions
n/a blamer Fixed Version: 1.0.1

Weakness: CWE-94

References