Vulnerability · Published Feb 24, 2020 · Assigned by hackerone

CVE-2020-8131

High 7.5

In plain English

A high-severity path traversal in yarn. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.2% (higher than 92% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)5.2%top 7.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Arbitrary filesystem write vulnerability in Yarn before 1.22.0 allows attackers to write to any path on the filesystem and potentially lead to arbitrary code execution by forcing the user to install a malicious package.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-yarnpkg1.22.4-2DEBIAN-CVE-2020-8131
Debian:13node-yarnpkg1.22.4-2DEBIAN-CVE-2020-8131
Debian:14node-yarnpkg1.22.4-2DEBIAN-CVE-2020-8131
npmyarn1.22.0GHSA-8mfc-v7wv-p62g

Affected products (as reported)

VendorProductVersions
n/a yarn Fixed Version: 1.22.0

Weakness: CWE-22

References