Vulnerability · Published Feb 14, 2020 · Assigned by hackerone
CVE-2020-8129
Critical 9.8
In plain English
A critical-severity code injection in script-manager. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.9% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)2.9%top 12.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
An unintended require vulnerability in script-manager npm package version 0.8.6 and earlier may allow attackers to execute arbitrary code.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | script-manager | 0.9.0 | GHSA-rhwf-hqpr-q8g2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | script-manager | Fixed version: 0.9.0 |
Weakness: CWE-94
References
- https://hackerone.com/reports/660563 x_refsource_MISC