Vulnerability · Published Feb 28, 2020 · Assigned by hackerone

CVE-2020-8127

Medium 6.1

In plain English

A medium-severity cross-site scripting in reveal.js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.1Medium
Exploit odds (30 days)1.2%top 31.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmreveal.js3.9.2GHSA-6vwx-mwp8-fh44

Affected products (as reported)

VendorProductVersions
n/a reveal.js Fixed version: 3.9.2

Weakness: CWE-79

References