Vulnerability · Published Feb 19, 2020 · Assigned by puppet
CVE-2020-7942
Medium 6.5
In plain English
A medium-severity security flaw in Puppet from Puppet. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Previously, Puppet operated on a model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure. When a node's catalog falls back to the `default` node, the catalog can be retrieved for a different node by modifying facts for the Puppet run. This issue can be mitigated by setting `strict_hostname_checking = true` in `puppet.conf` on your Puppet master. Puppet 6.13.0 and 5.5.19 changes the default behavior for strict_hostname_checking from false to true. It is recommended that Puppet Open Source and Puppet Enterprise users that are not upgrading still set strict_hostname_checking to true to ensure secure behavior. Affected software versions: Puppet 6.x prior to 6.13.0 Puppet Agent 6.x prior to 6.13.0 Puppet 5.5.x prior to 5.5.19 Puppet Agent 5.5.x prior to 5.5.19 Resolved in: Puppet 6.13.0 Puppet Agent 6.13.0 Puppet 5.5.19 Puppet Agent 5.5.19
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | puppet | 5.5.19 | GHSA-gqvf-892r-vjm5 |
| RubyGems | puppet | 6.13.0 | GHSA-gqvf-892r-vjm5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Puppet | Puppet | 5.5.x prior to 5.5.19Fixed in 5.5.196.x prior to 6.13.0Fixed in 6.13.0 |
| Puppet | Puppet Agent | 5.5.x prior to 5.5.19Fixed in 5.5.196.x prior to 6.13.0Fixed in 6.13.0 |
References
- https://puppet.com/security/cve/CVE-2020-7942/ x_refsource_CONFIRM