Vulnerability · Published Mar 31, 2020 · Assigned by GitHub_M

CVE-2020-5291Privilege escalation in setuid mode via user namespaces in Bubblewrap

High 7.2

In plain English

A high-severity security flaw in bubblewrap from containers. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.2High
Exploit odds (30 days)0.9%top 40.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Bubblewrap (bwrap) before version 0.4.1, if installed in setuid mode and the kernel supports unprivileged user namespaces, then the `bwrap --userns2` option can be used to make the setuid process keep running as root while being traceable. This can in turn be used to gain root permissions. Note that this only affects the combination of bubblewrap in setuid mode (which is typically used when unprivileged user namespaces are not supported) and the support of unprivileged user namespaces. Known to be affected are: * Debian testing/unstable, if unprivileged user namespaces enabled (not default) * Debian buster-backports, if unprivileged user namespaces enabled (not default) * Arch if using `linux-hardened`, if unprivileged user namespaces enabled (not default) * Centos 7 flatpak COPR, if unprivileged user namespaces enabled (not default) This has been fixed in the 0.4.1 release, and all affected users should update.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20bubblewrap0.4.1-r0ALPINE-CVE-2020-5291
Alpine:v3.21bubblewrap0.4.1-r0ALPINE-CVE-2020-5291
Alpine:v3.22bubblewrap0.4.1-r0ALPINE-CVE-2020-5291
Alpine:v3.23bubblewrap0.4.1-r0ALPINE-CVE-2020-5291
Alpine:v3.24bubblewrap0.4.1-r0ALPINE-CVE-2020-5291
Debian:12bubblewrap0.4.1-1DEBIAN-CVE-2020-5291
Debian:13bubblewrap0.4.1-1DEBIAN-CVE-2020-5291
Debian:14bubblewrap0.4.1-1DEBIAN-CVE-2020-5291

Affected products (as reported)

VendorProductVersions
containers bubblewrap < 0.4.1

Weakness: CWE-648 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

References