Vulnerability · Published Feb 12, 2020 · Assigned by GitHub_M
CVE-2020-5241XSS/Script injection vulnerability in matestack
High 7.7
In plain English
A high-severity security flaw in matestack-ui-core from matestack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.6%top 49.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
matestack-ui-core (RubyGem) before 0.7.4 is vulnerable to XSS/Script injection. This vulnerability is patched in version 0.7.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | matestack-ui-core | 0.7.4 | GHSA-3jqw-vv45-mjhh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| matestack | matestack-ui-core | < 0.7.4 |
Weakness: CWE-80 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N