Vulnerability · Published Jan 28, 2020 · Assigned by GitHub_M
CVE-2020-5211NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow
Medium 5.0
In plain English
A medium-severity buffer overflow in NetHack from NetHack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | nethack | 3.6.6-1 | DEBIAN-CVE-2020-5211 |
| Debian:13 | nethack | 3.6.6-1 | DEBIAN-CVE-2020-5211 |
| Debian:14 | nethack | 3.6.6-1 | DEBIAN-CVE-2020-5211 |
Affected products (as reported)
Weakness: CWE-120 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
References
- https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7 x_refsource_CONFIRM